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Toolbars 
Autocad provides several 
toolbars to access 
frequently used 
commands. 
The (1) Standard, (2) 
Object Properties, (3) 
Draw, and (4) Modify 
toolbars are displayed by 
default.  
Toolbars contain Icon 
Buttons (5).  
Tool Tip (6) 
Help Message (7) 
 
 
 

 
Toolbars can be Floated or Docked. Floating (8) and Docked (9) 
Floating toolbars (8) move freely in the drawing area and can be resized. 
 
Docked toolbars (9) are locked into place along the top, bottom or sides of the Autocad 
window. 
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The Function Keys 
 

Many of the modes described above can be controlled quickly using the keyboard function 
keys. In most cases this is quicker than using a pull-down or the command line. The function 
keys are arranged along the top of your keyboard. AutoCAD uses function keys F1 to F11. 
Their use is described below. 
 

F1 Help The F1 key on your keyboard brings up the "AutoCAD Help 
F2 Flipscreen The F2 key is used to toggle (turn on and off) the AutoCAD 

text window.  
F3 Osnap The F3 toggles running Object Snaps on and off.  
F4 Tablet The F4 key on your keyboard toggles tablet mode on and off.  
F5 Isoplanes The F5 key cycles through the Isoplanes. The options are 

Left, Top and Right.  
F6 Coordinate 

Display 
The F6 key is a three way toggle which changes the co-
ordinate reading in the status bar.  

F7 Grid  The F7 key is used to toggle grid mode on and off.  
F8 Ortho The F8 key on your keyboard can be used to toggle Ortho 

(orthogonal) mode on and off.  
F9 Snap The F9 key can be used to toggle Snap mode on and off.  
F10 Polar  The F10 key is used to switch polar tracking off and on.  
F11 Otrack   The F11 key toggles object snap tracking on and off.  

 
 

 
 
Cautions 
 
Never work for a long time before saving a drawing. 
 
Always save a drawing file on more than one disk. 
 
Q. How to convert a .BAK file to a .DWG?  
 
A. Just Rename the backup file to a drawing file with the .DWG extension.  
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DRAWING LIMITS 
 
A4 
Command:  LIMITS 8 
Reset Model space limits: 
Specify lower left corner or [ON/OFF] <0.0000,0.0000>: 8 
Specify upper right corner <420.0000,297.0000>: 297,210 8 
 
A3 
Command: LIMITS 8 
Reset Model space limits: 
Specify lower left corner or [ON/OFF] <0.0000,0.0000>: 8 
Specify upper right corner <297.0000,210.0000>: 420,297 8 
 
Command: Z 8  
ZOOM 
Specify corner of window, enter a scale factor (nX or nXP), or 
[All/Center/Dynamic/Extents/Previous/Scale/Window] <real time>: A 8 
Regenerating model. 
 
Units & Scales  
 
Introduction 
 
You cannot start creating sensible drawings with AutoCAD until you are familiar with scale, 
units and the commands you use to control them. This tutorial discusses these concepts, 
starting with the two most commonly asked questions in this subject area. 
 
At what scale should I draw? 
 
As a general rule, everything you draw with AutoCAD will be drawn full size. This often 
comes as quite a surprise to those who are new to CAD and have spent a number of years 
working on a drawing board. When you start drawing with AutoCAD you do not have to 
decide upon a drawing scale as you do when using a drawing board. When drawing on 
paper you must decide do draw at say, 1:20 or 1:200 depending upon the size of the object 
that you are drawing so that your scaled drawing will fit on the drawing sheet, be that A3 or 
A1. In AutoCAD you do not need to decide upon a drawing scale until you come to 
print the drawing and because the scaling of your drawing takes place at the printing 
stage, you can create drawings at a scale of 1:1.  
 
Am I drawing in metres or millimetres? 
 
Most people who use AutoCAD, draw using decimal drawing units. What these drawing 
units represent is entirely up to the individual. However, you must decide what units you will 
use before you start drawing. One drawing unit could represent one millimetre, one 
centimetre, one metre, kilometre, mile, furlong or fathom. It is entirely up to you. 
  
To change the unit type, you must use the Drawing Units dialogue box. 
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Units Control 
 
You now need to select 
what unit of measurement 
you want to work with. Such 
as Decimal (0.0000) or 
Architectural (0’- 0”). 
Next you should select how 
precise you want the 
measurements. This 
means, do you want the 
measurement rounded to a 
3 place decimal or the 
nearest 1/8”. 
 
 
 
Dialog box ‘’Drawing Units’’ 
 

 
Unit Precision 
How to set the units and Precision. 
 
1- Select the units command using one of the following: 
 

Type UNITS 8 
Pulldown > Format >Units 

 

And the dialog box ”Drawing Units” will 
appear 

2- Select the appropriate Type such as: Decimal or Architectural. 
3- Select the appropriate Precision associated with the “type”. 
4- Select the OK button to save your selections. 
  
Drawing Lines,Circles and RECtangles by using the curser only 
 
Lines are probably the most simple of AutoCAD objects. Using the Line command, a line can 
be drawn between any two points picked within the drawing area. Lines are usually the first 
objects you will want to draw when starting a new drawing. A line can be one segment or a 
series of connected segments. Each segment is an individual object. 

 
Lines are drawn by specifying the locations for the endpoints.  
Move the curser to the location of the “first” endpoint then press the left mouse button. 
Move the curser again to the “next” endpoint press the left mouse button. 
Contiue locating “next” endpoints until you want to stop.  
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Drawing Lines  
Using Continue  
To draw a line segment between any two 
points P1 and P2   

 
Command: LINE 8 
Specify first point: (pick First point) 8 
Specify next point or [Undo]: (pick Second 
point) 8 
Specify next point or [Undo]: (pick Third 
point) 8 
Specify next point or [Undo]:  8  (to end)  

To draw a rectangle using the LINE 
command  
Using Continue and Close 
Command: LINE 8 
Specify first point: (pick First point) 8 
Specify next point or [Undo]: (pick Second 
point) 8 
Specify next point or [Undo]: (pick Third 
point) 8 
Specify next point or [Undo]: (pick Fourth  
point) 8 
Specify next point or [Undo]:C 8  (Joins the 
fourth point with the first point)  

                 
 

Drawing lines using the LINE command with Continue and Close. 
  

You can continue picking points and AutoCAD will draw a straight line between each picked 
point and the previous point. Each line segment drawn is a separate object and can be 
moved or erased as required. To end this command, just hit the  key on the keyboard.  
 

There are 3 ways to Stop drawing line: 
 

Press ENTER key 
Press SPACE BAR  
Press the RIGHT MOUSE BUTTON then select ENTER from the short cut menu. 
 

To draw perfectly Horizontal or Vertical lines select the ORTHO mode by clicking on 
the ORTHO button on the Status Bar or pressing F8 
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The Circle command is used to draw circles. There are a number of ways you can define the 
circle. The default method is to pick the centre point and then to either pick a second point on 
the circumference of the circle or enter the circle radius at the keyboard. 
 
 
Command: Circle 8 
Specify center point for circle or [3P/2P/Ttr (tan tan, 
radius)]: (pick P1) 8 
Specify radius of circle or [Diameter]: (pick P2 or 
enter the exact radius) 8  
 
The Rectangle command is used to draw a 
rectangle whose sides are vertical and horizontal. 
The position and size of the rectangle are defined 
by picking two diagonal corners. The rectangle isn't 
really an AutoCAD object at all. It is, in fact, just a 
closed polyline which is automatically drawn for you. 

 
Command: REC 8 
Specify first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]: (pick P1) 8 
Specify other corner point or [Dimensions]: (pick P2) 8 
 
SAVING A DRAWING 
After you have completed a drawing, it is very important to save it. Learning how to save a 
drawing correctly is almost more important than making the drawing. If you can’t save 
correctly, you will lose the drawing and hours of work. 
 
There are two command for saving a drawing. Save and Save As. I prefer to use Save As. 
The  Save As command always pauses to allow you to choose where you want to store the 
file and what name to assign to the file. This may seem like a small thing, but it has saved 
me many times from saving a drawing on top of another drawing by mistake. The Save 
command will automatically save the file either back to where you retrieved it or where you 
last saved a previous drawing. Neither may be the correct destination. So play it safe, use 
Save As for now.  
1. Start the command by using one of following methods: 
 
Type Save As 8 
Pulldown > File > SaveAs 
Toolbar: No icon for Save 
As, only for Save (Don’t 
use it) 
 
And the dialog box ” Save 
As” will appear 
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2. Select the appropriate drive and directory from the “Save As” box. 
 This is where your drawing will be saved) 
3. Type the new drawing file name in the “File Name” box. 
4. Select the “Save” button. 
 

Coordinate Systems 
 

1- Absolute coordinates  
 

Draw a line AB, A(20,10), and B(30,40). 
 

Command: LINE 8 
Specify first point: 20,10 8 
Specify next point or [Undo]: 30,40 8  LINE  I 
Specify next point or [Undo]: 8 
 

2- Relative Coordinates  
Relative rectangle coordinates  

 

Draw a linen AC, A(20,10), C has a distance x = 30, and y = 40 from point A. 
 

Command: LINE 8 
Specify first point: 20,10 8 
Specify next point or [Undo]: @30,40 8 LINE  II 
Specify next point or [Undo]: 8 
 

Relative polar coordinates  
 

Draw a line AD, A(20,10), D has a distance 50 from point A and 30o slope from horizontal. 
 

Command: LINE 8 
Specify first point: 20,10 8 
Specify next point or [Undo]: @50<30 8  LINE  III 
Specify next point or [Undo]: 8 
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Drawing Aids 
Introduction  
 

Drawing with AutoCAD is really just like drawing on a drawing board. Most newcomers to 
Computer Aided Design assume that they will need to learn how to draw all over again. In 
fact, many of the drawing aids that AutoCAD provides are analogous to traditional drafting 
tools. Just as you have a parallel motion and set squares to help you draw horizontal and 
vertical lines on a drawing board, AutoCAD has similar drawing aids which can help you to 
draw horizontal and vertical lines on a computer. This means that in many respects, the 
drawing techniques are very similar. If you ever get stuck, think how you would complete a 
task on a drawing board and then look for a similar way to do it with AutoCAD. 
 

Ortho Mode 
 

Status Bar  
Pull-down None 
Keyboard : ORTHO or F8 
 

Ortho is short for Orthogonal, which means either vertical or horizontal. Like the other 
options on the status bar, Ortho is not really a command; it is a drawing mode which can 
either be turned on or off. Ortho mode can be toggled on or off in one of three ways.  
 

Ortho can also be toggled on and off using the F8 Function key. 
 

The quickest way is just to click on the ORTHO button on the status bar. The appearance of 
the button tells you whether Ortho is currently turned on or turned off. When Ortho is turned 
on, the ORTHO button appears pressed in. You can see how this appears by looking at the 
status bar illustration below. In the illustration, Ortho is turned on but Grid and Snap are 
turned off. 
 

 
 
Finally, you can also type ORTHO at the command prompt as in the command sequence 
below. Using Ortho is the equivalent of using your parallel motion and set square on a 
drawing board. With Ortho mode turned on you can only draw lines which are either vertical 
or horizontal. Turn Ortho mode on now and draw some lines to get a feeling for how it works. 
 

Command: ORTHO  
Enter mode [ON/OFF] <OFF>: (type ON or OFF then press ) 
 
The Drawing Grid 

Status Bar  (right-click for settings) 

Pull-down None 

Keyboard GRID or F7  

The drawing grid is a regular pattern of dots displayed on the screen which acts as a visual 
aid, it is the equivalent of having a sheet of graph paper behind your drawing on a drawing 
board. You can control the grid spacing, so it can give you a general idea about the size of 
drawn objects. It can also be used to define the extent of your drawing.  
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Grid spacing set to 10x10 drawing units                Grid spacing set to 20x20 drawing units. 
Snap ON                                                                      Snap OFF 

  
Command: Grid  
Specify grid spacing(X) or [ON/OFF/Snap/Aspect] <10>:  
 

Although you can use the command line to control the visibility of the grid by using the "ON" 
and "OFF" options this is more easily achieved using the F7 key or, better still, by clicking the 
GRID button on the status bar.  
 

Command: Grid  
Specify grid spacing(X) or [ON/OFF/Snap/Aspect] <10>: ON  
 

Grid mode and X/Y spacing can also be set using the Drafting Settings dialogue box. You 
can access grid Grid mode and X/Y spacing can also be set using the Drafting Settings 
dialogue box. You can access grid settings by right-clicking the Grid button on the status 
bar and selecting Settings… from the menu. You can also do this from the pull-down menu,  
 

By using Relative Rectangle Coordinates Draw above TEMPLATE 1 starting from P1 if the 
absolute coordinate of P6(0,0). 
Specify next point or [Undo]: @0,5 8 
Command: Snap  
settings by right-clicking the Grid button on the status bar and selecting Settings… from the 
menu. You can also do this from the pull-down menu,  

Tools>Drafting Settings… 
and click on the "Snap and Grid" tab.  
 

Snap Mode 
Status Bar   (right-click for settings)  
Pull-down  None 
Keyboard SNAP or F9 

 
Snap mode takes AutoCAD one step further than the drawing board. With Snap mode turned 
on AutoCAD only allows you to pick points which lie on a regular grid. The Snap grid is 
completely independent of the display grid. However, the Grid spacing and Snap spacing are 
usually set to the same value to avoid confusion.  
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Command: Snap  
Specify snap spacing or [ON/OFF/Aspect/Rotate/Style/Type] <10>:  
When Snap mode is turned on and the Grid is displayed, the Snap and Grid spacings are the 
same and the crosshairs will jump from one grid point to another as you move across the 
screen. This makes it very easy to draw objects which have a regular shape. The Snap 
command is used to set the snap spacing and to toggle Snap mode. 
 
Command: Snap  
Specify snap spacing or [ON/OFF/Aspect/Rotate/Style/Type] <10>: ON  
The Snap option allows you to automatically set the grid spacing to the current snap spacing. 
You can also change the aspect ration of the grid. By default, the X and Y spacing of the Grid 
are the same, resulting in a regular square matrix of grid points. But you can display a grid 
with different X and Y spacing by using the "Aspect" option. 
 
Example 1 
 
Command: LINE 8  
Specify first point: Pick P1 
Specify next point or [Undo]: @7,0 8 
Specify next point or [Undo]: @0,5 8 
Specify next point or [Close/Undo]: @-3,0 8 
Specify next point or [Close/Undo]: @0,2 8 
Specify next point or [Close/Undo]: @3,0 8 
Specify next point or [Close/Undo]: @4,0 8 
Specify next point or [Close/Undo]: u 8 
Specify next point or [Close/Undo]: @0,4 8 
Specify next point or [Close/Undo]: @-3,3 8 
Specify next point or [Close/Undo]: @-2,-1 8 
Specify next point or [Close/Undo]: @-2,1 8 
Specify next point or [Close/Undo]: @-3,-3 8 
Specify next point or [Close/Undo]: @0,-3 8 
Specify next point or [Close/Undo]: @4,0 8 

 
 

TEMPLATE 1
Specify next point or [Close/Undo]: @0,-5 8 
Specify next point or [Close/Undo]: @-4,0 8 
Specify next point or [Close/Undo]: C Close 8 
 
Problem 1 
By using Relative Rectangle Coordinates Draw above TEMPLATE 1 starting from P1 if the 
absolute coordinate of P6(0,0). 
 

P1  P4  P7  P10  P13 
 

P2  P5  P8  P11  P14 
 

P3  P6 0.0 P9  P12  P15 
 

 
Example 2 
 

By using Relative Polar Coordinates Draw a TEMPLATE 2 starting from P1(10,0) in a 
clockwise direction. 
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Command: L   
Specify first point: 10,0  
Specify next point or [Undo]: @50,0  
Specify next point or [Undo]: @57<45  
Specify next point or [Close/Undo]: @31<120  
Specify next point or [Close/Undo]: @56<155  
Specify next point or [Close/Undo]: @35<-145  
Specify next point or [Close/Undo]: @28<-45  
Specify next point or [Close/Undo]: @30<-120  
Specify next point or [Close/Undo]: C   

 
TEMPLATE  2 

Problem 2: 
By using Relative Polar Coordinates Draw TEMPLATE 2 starting from P1(10,0) in anti 
clockwise direction.  
 

P1  P4  P7 
 

P2  P5  P8 
 

P3  P6    

 
Polar Tracking 
 
Draw a line BC starting from point B. B has a horizontal distance of 100 mm from A, Fig 1.  
 

Command: ID  
Specify point: Pick point A   
 X = 221     Y = 185     Z = 0 
 

Now, A become as a point (0,0) in Cartesian coordinates. 
 

Command: LINE  
LINE Specify first point: @100<0  
Specify next point or [Undo]:  @75<90  
Specify next point or [Undo]:  

Fig. 1                          
 
 
Draw a line EF starting from point B to point F as shown in Fig. 2 
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Fig. 2 

Command: LINE 8 
Specify first point: TRACKING  
First tracking point: Pick point A  
Next point  (Press ENTER to end tracking): @100<0  
Next point  (Press ENTER to end tracking): @50<90  
Next point  (Press ENTER to end tracking): @130<180  
Next point  (Press ENTER to end tracking): @33<90  
Next point  (Press ENTER to end tracking):  
Specify next point or [Undo]: @133<30  
Specify next point or [Undo]:  

 
Direct Distance Entry DDE   
 

Direct distance entry DDE enables you to draw an object, such as a line, by pointing in a 
particular direction with the cursor and entering a distance at the command line. 
 

How does it work? 
 

Example 3: Draw a series of connected lines Shown in geometry starting with a horizontal 
line from point A. 
 
 

1- Start the Line command. Pick any point A. Or press F10 on Polar Tracking. 
2- Use the POLAR button on the status bar to turn on Polar Tracking.   
3- Move your cursor to the right of the first pick point.  

Hold your cursor in this position and simply enter 29 at the keyboard.  
When you hit the ENTER key, a line segment is drawn, 29 units long and in the direction 
you were pointing.  
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Fig 3 

 
Drawing First segment 

 

Obviously, you could vary this sequence to 
get different effects.  

Use the POLAR button on the status bar to 
turn on Polar Tracking with angle of 15o. 

If you only want to draw horizontal or vertical 
lines, you could use Ortho rather than Polar 
Tracking.  

You might even want to turn both Ortho and 
Polar Tracking off and use free angles. 

 
 

Drawing Second and Third segment 
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The Polyline Command 
Toolbar  
Pull-down: Draw Polyline 
Keyboard: PLINE  short-cut: PL 
 
The Polyline or Pline command is similar to the line command except that the resulting 
object may be composed of a number of segments which form a single object. In addition to 
the two ends a polyline is said to have vertices (singular vertex) where intermediate line 
segments join. In practice the Polyline command works in the same way as the Line 
command allowing you to pick as many points as you like. Again, just hit to end. As with 
the Line command, you also have the option to automatically close a polyline end to end. To 
do this, type C to use the close option instead of hitting . Follow the command sequence 
below to see how this works. 
 
Options  
 
[Arc/Halfwidth/Length/Undo/Width] 
 
Try experimenting with options such as Arc 
and Width and see if you can create 
polylines like the ones in the illustration. 
The Undo option is particularly useful. This 
allows you to unpick polyline vertices, one 
at a time so that you can easily correct 
mistakes. 
 

 

Polylines can be edited after they are created to, for example, change their width. You can 
do this using the PEDIT command, Modify>Object>Polyline from the pull-down menu. 
 
The Spline Command 
Toolbar  
Pull-down: Draw>Spline 
Keyboard: SPLINE  short-cut: SPl  
 

 
Command: Spline  
Specify first point or [Object]: (Pick P1) 
Specify next point: (Pick P2) 
Specify next point or [Close/Fit tolerance] <start tangent>:(Pick P3) 
……………………………………………….. 

Specify next point or [Close/Fit tolerance] <start tangent>:(Pick P10)  
You can create linear approximations to splines by smoothing polylines with the PEDIT 
command, Modify>Polyline from the pull-down menu. However, you can also turn polylines 
into true splines using the Object option of the Spline command. 
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Problem 3 
Draw a Hexagon (Edge = 39 units) by using the Polar Tracking with angle of 15o.  
 
Problem 4 
Draw a Hexagon (Edge = 14 units) by using the Polar Tracking with angle of 60o.  
 
Problem 5 
Draw an Octagon  (Edge = 39 units) by using the Polar Tracking with angle of 45o.  
 
The Erase Command 

Toolbar:   
Pull-down: Modify>Erase 
Keyboard: ERASE or E 
 
The Erase command is one of the simplest AutoCAD commands and is one of the most used. The 
command erases (deletes) any selected object(s) from the drawing.  
 

Command: ERASE  
Select objects: (pick an object to erase) 
Select objects: (to end the selection and erase the object) 

 
You can use the DELETE ICON to delete any object on the screen. 

Pick objects then click a DELETE ICON. 
Object Selection 
Before you start to use the AutoCAD Modify commands, you need to know something about selecting 
objects. All of the Modify commands require that you make one or more object selections. AutoCAD 
has a whole range of tools which are designed to help you select just the objects you need.  
 
Selecting Objects by Picking 
The most obvious way to select an object in AutoCAD is simply to pick it. When you start a Modify 
command such as ERASE, two things happen. First, the cursor changes from the usual crosshairs to 
the pickbox and second, you will then the "Select objects" prompt on the command line.  
 
Select objects:  
To select an object, place the pickbox over a part of the object and left-click the mouse. When the 
object has been picked it is highlighted in a dashed line to show that it is part of the current selection 
and the command line reports "1 found". You will now see the "Select objects" prompt on the 
command line again. At this point you can continue adding more objects to the current selection by 
picking them or you can press  or the Space Bar to complete the selection. 
 
Window Selection 
The Window option is invoked by typing W in response to the "Select objects" prompt. Window allows 
you to define a rectangle using two points in exactly the same way as the RECTANGLE command. 
Once the window is defined, all objects which lie entirely within the window will be selected. 
 
Crossing Window Selection 
The Crossing Window option is invoked by typing C at the "Select objects" prompt and is a variation of 
the Window command. The command sequence is exactly the same but objects are selected which lie 
entirely within the window and those which cross the window border. 
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       Window Selection                         Crossing Window Selection 
 
Object Snap 

  
Object Snaps 

Object snaps (Osnaps) are one of the handiest tools in AutoCAD. Without them, you would 
have a lot of trouble doing even the simplest dimension accurately. Before discussing how 
they are used, first think about what they are. Their name, "object snaps" means that they 
snap to objects, or more precisely, they snap to specific parts of an object. A line for example 
has 3 points that you can snap to: a midpoint and two endpoints. A circle has 5 points: a 
center and 4 quadrants. To use Osnaps effectively, you must know what points an object has 
that you are able to snap to. 

There are also some Osnaps that are not precise. These allow you to snap to (sometimes) 
arbitrary points along an object. These would include nearest, tangent, perpendicular and to 
some extent, intersection. 

There are two different ways of working with Osnaps; in running mode or invoking them 
individually as required. Running Osnaps mean that certain ones are turned on and running 
in the background. This means that they are available when needed in the middle of a 
command. 

Sometimes you may need one Osnap that isn't one you have selected in running mode. In 
this case you can turn it on for one-time use. There are a few ways of doing this: you can 
select the icon for the Osnap you need, you can type in the 3 letter shortcut, or you can bring 
up the Osnap dialog box and turn it on ('OS), or even shift+right-click and pick from the 
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menu. I recommend learning the 3 letter shortcuts and typing them in when required. This is 
generally the fastest way to get your Osnap on, plus it doesn't leave it on if you don't need it 
afterwards. Having the icons up your screen works, but takes up valuable screen area. Try 
each method and see which one works best for you. 

In most cases you want to turn on all the osnaps while drawing as you could accidently snap 
to a point you don't want. For example, the endpoint and a perpendicular point could be very 
close - so you need to be careful when using perpendicular. 

Running object snaps can be configured using the Object Snap tab of the Drafting Settings 
dialogue box, illustrated below. This tabbed dialogue box and also includes settings for Snap 
and Grid and for Polar Tracking 
 

 
  

Object Snap Dialogue Box  
 
Example: Draw  a Line from END of a  line thru INTersection of two lines 
 
Command: LINE  
LINE Specify first point: END  (Pick END of line ) 
Specify next point or [Undo]: INT  (Pick the intersection of two lines) 
Specify next point or [Undo]:  
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Example: Draw a Line tangent to two circles. 
 
Command: line  
Specify first point: tan   (Pick a point nearest to the tangent on circle) 
Specify next point or [Undo]: tan  (Pick a point nearest to the tangent on other circle) 
Specify next point or [Undo]:  

 
Draw Toolbar  

This tutorial is designed to show you how some of the 
AutoCAD Draw commands work. Not all of the Draw 
commands that appear on the Draw toolbar are 
covered in this tutorial. Blocks, Hatch and Text for 
example are all tutorial topics in their own right! 
 
The Draw commands can be used to create new 
objects such as lines and circles. Most AutoCAD 
drawings are composed purely and simply from these 
basic components. A good understanding of the Draw 
commands is fundamental to the efficient use of 
AutoCAD. 

 
 

 
The Draw toolbarThe sections below cover the most frequently used Draw commands such 
as Line, Polyline, Circle, Polygon, Rectangle, as well as the more advanced commands 
like Multiline and Multiline Style.  
 
In common with most AutoCAD commands, the Draw commands can be started in a 
number of ways. Command names or short-cuts can be entered at the keyboard, 
commands can be started from the Draw pull-down menu, shown on the right or from the 
Draw toolbar.  
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Drawing Lines 
 

The Line Command 

Toolbar   
Pull-down  Draw > Line, short-cut L 
Command: Line  ( L ) 
 
Draw a Square, length of side = 30 mm from the vertex 100,100  
 
Command: LINE  
Specify first point: 100,100  
Specify next point or [Undo]: @30<0  (OR @30, 0 ) 
Specify next point or [Undo]: @30<90  (OR @0, 30 ) 
Specify next point or [Close/Undo]: @30<180  (OR @-30, 0 ) 
Specify next point or [Close/Undo]: C  
 
Draw an equilateral triangle, length of side =40 mm from the vertex 60,70.  
 
Command: LINE  
Specify first point: 60,70  
Specify next point or [Undo]: @40<0  (OR @40, 0 ) 
Specify next point or [Undo]: @40<120   
Specify next point or [Close/Undo]: C  
The Construction Line Command 

Toolbar   
Pull-down  Draw > Xline,  short-cut Xl 
Command: Xline   ( Xl ) 
 
Command: Xl  
XLINE Specify a point or [Hor/Ver/Ang/Bisect/Offset]: pick a point  
Specify through point: pick a second point  
Specify through point: pick a point to position the line 
 
Drawing horizontal construction lines 
Command: XLINE  
Hor/Ver/Ang/Bisect/Offset/<From point>: H  
Through point: pick a point to position the line 
Through point: to end or pick a point for another horizontal line  
 
 
The Rectangle Command 

Toolbar  
Pull-down Draw >Rectangle 
Keyboard RECTANGLE 
short-cuts  REC, RECTANG 
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The Rectangle command is used to draw a rectangle whose sides are vertical and horizontal. The 
position and size of the rectangle are defined by picking two diagonal corners. The rectangle isn't 
really an AutoCAD object at all. It is, in fact, just a closed polyline which is automatically drawn for you. 
 
Notice that, instead of picking a second point to draw the rectangle, you have the option of entering 
dimensions. Say you wanted to draw a rectangle 20 drawing units long and 10 drawing units wide. The 
command sequence would look like this: 
 
Command: RECTANG  
Specify first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]: (pick a point) 
Specify other corner point or [Dimensions]: D  
Specify length for rectangles <0.0000>: 20  
Specify width for rectangles <0.0000>: 10  
Specify other corner point or [Dimensions]: (pick a point to fix the orientation) 
 

Options for drawing RECtangle:  
 

 
The Rectangle command also has a number of options. Width works in the same way as for the 
Polyline command. The Chamfer and Fillet options have the same effect as the Chamfer and Fillet 
commands, see the Modifying Objects tutorial for details. Elevation and Thickness are 3D options. 

 

     
 
The Polygon Command 

Toolbar  
Pull-down: Draw>Polygon 
Keyboard: POLYGON, short-cut POL 
 
The Polygon command can be used to draw any regular polygon from 3 sides up to 1024 
sides. This command requires four inputs from the user, the number of sides, a pick point for 
the centre of the polygon, whether you want the polygon inscribed or circumscribed and then 
a pick point which determines both the radius of this imaginary circle and the orientation of 
the polygon. The polygon command creates a closed polyline in the shape of the required 
polygon. 

Command Sequence 
Command: POLYGON  
Enter number of sides <4>: 5  
Specify center of polygon or [Edge]: pick P1  
Enter an option [Inscribed in circle/Circumscribed about circle] <I>: (to accept the inscribed default 
or type C for circumscribed) 
Specify radius of circle: (pick P2 or enter exact radius) 
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This command also allows you to define the polygon by entering the length of a side using 
the Edge option. You can also control the size of the polygon by entering an exact radius for 
the circle. Follow the command sequence below to see how this command works. 
 
Example: Draw a Pentagon, length of side = 30 mm from the vertex 100,100 
Command: Polygon  
Enter number of sides <3>: 5  
Specify center of polygon or [Edge]: E  
Specify first endpoint of edge: 100,100  
Specify second endpoint of edge: @30<0  

    
Draw a Square, length of side = 20 mm from the vertex 100,100  
 
Command: Polygon  
Enter number of sides <5>: 4  
Specify center of polygon or [Edge]: E  
Enter an option [Inscribed in circle/Circumscribed about circle] 
<I>: 100,100  
Specify radius of circle: @20<0  
 
The Circle Command 
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Toolbar:  
Pull-down: Draw Circle Center, Radius 
Keyboard: CIRCLE short-cut C 
 
The Circle command is used to draw circles. There are a number of ways you can define the 
circle. The default method is to pick the centre point and then to either pick a second point on 
the circumference of the circle or enter the circle radius at the keyboard. 
 
Draw a circle which the center is at absolute coordinate (0,10) and radius is 53 unit.  
 
Command: CIRCLE  
Specify center point for circle or [3P/2P/Ttr (tan tan radius)]: 0, 10   
Specify radius of circle or [Diameter] <50.0195>: 53  
 
Draw a circle which the center is at absolute coordinate (15,32) and Diameter is 18 
unit.  
Command: CIRCLE  
Specify center point for circle or [3P/2P/Ttr (tan tan radius)]: 15, 32   
Specify radius of circle or [Diameter] <50.0195>: D  
Specify Diameter of circle <100.390>: 18  
 
The circle command gives you three extra options to define a circle. 
3P  which uses any three points on the circumference,  
2P which uses two points on the circumference to form a diameter and  
TTR which stands for Tangent Tangent Radius. 
 
3 Points   
Command: CIRCLE  
Specify center point for circle or [3P/2P/Ttr (tan tan radius)]: 3P   
Specify radius of circle or [Diameter] <50.0195>: Pick P1  
Specify radius of circle or [Diameter] <50.0195>: Pick P2   
Specify radius of circle or [Diameter] <50.0195>: Pick P3  
 
2 Points   
Command: CIRCLE  
Specify center point for circle or [3P/2P/Ttr (tan tan radius)]: 2P   
Specify radius of circle or [Diameter] <50.0195>: Pick P1  
Specify radius of circle or [Diameter] <50.0195>: Pick P2   
 

                                          
 
Tangent Tangent Radius TTR 
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Command: CIRCLE  
Specify center point for circle or [3P/2P/Ttr (tan tan radius)]: TTR   
Specify radius of circle or [Diameter] <50.0195>: Pick P1    
Specify radius of circle or [Diameter] <50.0195>: Pick P2   
Specify radius of circle <49.315>: 15  
 
Tangent Tangent Tangent 
 
Command: CIRCLE  
Specify center point for circle or [3P/2P/Ttr (tan tan radius)]: 3P   
Specify radius of circle or [Diameter] <50.0195>: (Type TAN ) Pick P1  
Specify radius of circle or [Diameter] <50.0195>: (Type TAN ) Pick P2   
Specify radius of circle or [Diameter] <50.0195>: (Type TAN ) Pick P3   
 
Draw a circle tangent to a given triangle. 
Draw a circle through a three point of triangle. 
 

The Donut Command 
Toolbar custom   
Pull-down  Draw Donut 

Keyboard DONUT  short-cut DO 

This command draws a solid donut shape, actually it's just a closed polyline consisting of two arc segments 
which have been given a width. AutoCAD asks you to define the inside diameter i.e. the diameter of the 
hole and then the outside diameter of the donut. The donut is then drawn in outline and you are asked to 
pick the centre point in order to position the donut. 

 

then drawn in outline and you are asked to pick the centre point in order to position the 
donut. You can continue picking centre points to draw more donuts or you can hit to end 
the command. Surprisingly, donuts are constructed from single closed polylines composed of 
two arc segments which have been given a width. Fortunately AutoCAD works all this out for 
you, so all you see is a donut.  

Command Sequence 
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Draw a donut, inside diameter =1.5 and outside diameter 2.25.  

Command: DONUT  
Specify inside diameter of donut <0.5000>: 1.5  
Specify outside diameter of donut <1.5000>: 2.25  
Specify center of donut or <exit>: (pick P1) 
Specify center of donut or <exit>: (to end or continue to pick for more donuts) 
 
The Ellipse Command 

Toolbar:  
Pull-down: Draw > Ellipse > Axis, End 
Keyboard: ELLIPSE  short-cut: EL  
  
The Ellipse command gives you a number of different creation options. The default option is 
to pick the two end points of an axis and then a third point to define the eccentricity of the 
ellipse. After you have mastered the default option, try out the others. 

 

 

 
Bhatch 
Command: (Bhatch or BH) 8  
………..The Hatch Dialog Box will appear 
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Hatch Dialog Box 
Choose: 
Type: User defined 
Angle: 45o 
Spacing: 3 units 
Pick Points: Pick a point inside closed area  8 Composition:  Associative or 
Nonassociative  

 
The Arc Command 
Toolbar: Draw>  
Pull-down: Draw >Arc > 3 Points 
Keyboard: ARC    short-cut: A 
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The Arc command allows you to draw an arc of a circle. There are numerous ways to define 
an arc, the default method uses three pick points, a start point, a second point and an end 
point. Using this method, the drawn arc will start at the first pick point, pass through the 
second point and end at the third point. Once you have mastered the default method try 
some of the others. You may, for example need to draw an arc with a specific radius. All of 
the Arc command options are available from the pull-down menu. 
 
 

Command: ARC  
Specify start point of arc or [Center]: pick P1 
Specify second point of arc or [Center/End]: pick P2 
Specify end point of arc: pick P3 
 
 
It is also possible to create an arc by trimming a 
circle object. In practice, many arcs are actually 
created this way. See the Trim command on the 
Modifying Objects tutorial for details. 

The Revcloud Command 
Toolbar: Draw   
Pull-down: Draw Revision Cloud 
Keyboard REVCLOUD 
 
The Revcloud command is used to draw a "freehand" revision cloud or to convert any closed 
shape into a revision cloud. 
 
Command Sequence  
Command: Revcloud  
Minimum arc length: 5 Maximum arc length: 6   Style: 
Normal 
Specify start point or [Arc length/Object/Style] <Object>: a  
Specify minimum length of arc <5>: 10  
Specify maximum length of arc <10>: 12  
Specify start point or [Arc length/Object/Style] <Object>:Pick 
P1) 
Guide crosshairs along cloud path... 
Move the mouse to form a closed shape; the command 
automatically ends when a closed shape is formed. 
Reverse direction [Yes/No] <No>: 
 

 

The Point Command 
Toolbar: Draw  
Pull-down: Draw Point Single Point 
Keyboard POINT short-cut  PO 
 
The point command will insert a point marker in your drawing at a position which you 
pick in the drawing window or at any co-ordinate location which you enter at the 
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keyboard. The default point style is a simple dot, which is often difficult to see but you 
can change the point style to something more easily visible or elaborate using the 
point style dialogue box. Points can be used for "setting out" a drawing in addition to 
construction lines. You can Snap to points using the Node object snap. See the 
Object Snap tutorial for details. 

Command Sequence 
Command: POINT  
Current point modes: PDMODE=0 PDSIZE=0.0000 
Specify a point: pick any point 
 
Strangely, in Multiple Point mode (the default for the Point button on the Draw 
toolbar) you will need to use the escape key (Esc) on your keyboard to end the 
command. The usual right-click or enter doesn't work. 
 
Modify Toolbar 
 
AutoCAD drawings are rarely completed simply by drawing lines, circles etc. Most 
likely you will need to Modify these basic drawing objects in some way in order to 
create the image you need. AutoCAD provides a whole range of modify tools such as 
Move, Copy, Rotate and Mirror. As you can see, the command names are easily 
understandable. However, the way these commands work is not always obvious. 
This tutorial is designed to show you how all of the Modify commands work.  
 

Erase Mirror Array Rotate Erase Extend Break Fillet

Copy Offset Move Scale
Lengthen

Trim
Chamfer

Explode

Erase Mirror Array Rotate Erase Extend Break Fillet

Copy Offset Move Scale
Lengthen

Trim
Chamfer

Explode

 
 
As is usual with AutoCAD, the Modify tools can be accessed in one of three ways, 
from the Keyboard, from the Pull-down Menu and from the Toolbar. All of the 
Modify tools are available from the Modify pull-down and the Modify toolbar. In each 
section below, the toolbar, pull-down and keyboard options are given. The method 
you choose is entirely up to you. Ultimately you will use the method that you feel 
most comfortable with or the one you find most efficient. AutoCAD allows great 
flexibility and there aren't any right or wrong ways of working. That said, it should be 
pointed out that the use of toolbars in AutoCAD is almost always quicker than any 
other method.  
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Customize dialogue box 

 
The Modify toolbar is usually displayed by default but if it is not already displayed, you can 
display it using the TOOLBAR command, View>Toolbars… from the Pull-down Menu. 
When the Toolbar dialogue box (shown above) appears, simply check the box next to 
"Modify" in the toolbars list. Many AutoCAD users work with the Modify toolbar permanently 
Docked on their screen because it gives one-click access to all of the commands, making the 
drawing process much more efficient. 

The Erase Command 

Toolbar:  
Pull-down: Modify>Erase 
Keyboard: ERASE or E   
The Erase command is one of the simplest AutoCAD commands and is one of the most used. 
The command erases (deletes) any selected object(s) from the drawing. Remember you can 

always get deleted objects back by typing U to undo,   from the Standard toolbar or by 
using the OOPS command. 
 

Command: ERASE  
Select objects: (pick an object to erase)  
Select objects: (to end the selection and erase the object)  
 
If you simply want to erase the last object you created you can type L at the "Select objects" 
prompt. The last object will be highlighted and you can then select more objects or  
to end the command.  
 

Command: ERASE 8 
Select objects: 1 found 8 
Select objects: 8 
 

Command: ERASE 8 
Select objects: all 8   
Select objects: 8 
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The Copy Command 

Toolbar:  
Pull-down:  Modify>Copy 
Keyboard:  COPY or CP 
The Copy command can be used to create one or more duplicates of any drawing object or 
objects which you have previously created. Copy is a very useful and time-saving command 
because you can create very complex drawing elements and then simply copy them as many 
times as you like. 

Command: COPY  
Select objects: (pick object to copy, P1)  
Select objects: (to end selection)  
Specify base point or displacement, or [Multiple]: (pick P2 or M for multiple copies) 
Specify second point of displacement or <use first point as displacement>: (pick P3) 
 
The multiple option allows you to create additional copies of the selected object(s) by picking 
as many new points as you like. To end a multiple copy, just hit the key. 
 
Notice that the "Base point", P2 and the "Second point", P3 do not have to be picked on or 
near the object. The two points are simply used to indicate the distance and direction of the 
copied object from the original object. 
 

Canceling and Undoing a command: 
If you are in a command and you want to cancel or get out of that command, press the ESC 
(Escape) key on the keyboard. 
 

Similarly, sometimes you unintentionally erase some object from the screen. When you 
discover such an error, you can correct it by restoring the erased object by means of the 
OOPS command. The OOPS command restores objects that have been accidentally erased 
by the previous ERASE command, 
The Mirror Command 

Toolbar:  
Pull-down: Modify>Mirror 
Keyboard: MIRROR 
 
The Mirror command allows you to mirror selected objects in your drawing by picking them 
and then defining the position of an imaginary mirror line using two points 
 
Command: MIRROR  
Select objects: (pick object to mirror, P1)  
Select objects: (to end selection)  
Specify first point of mirror line: (pick P2)  
Specify second point of mirror line: (pick P3)  
Delete source objects? [Yes/No] <N>: (for No to keep the original object) 
 
Notice that in the command sequence above, pressing the  key when asked whether to 
"Delete source objects?" resulted in a "No" response. This is because "No" is the default 
option. AutoCAD always shows the default option within triangular brackets, in this case 
"<N>". Many AutoCAD commands offer default options. They are usually the most commonly 
used and you need only right-click and select "Enter" from the menu or press on the 
keyboard to accept them. 
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The Offset Command 

Toolbar:  
Pull-down: Modify>Offset 
Keyboard: OFFSET 
 
Offset is probably one of the most useful commands for constructing drawings. The Offset 
command creates a new object parallel to or concentric with a selected object. The new 
object is drawn at a user defined distance (the offset) from the original and in a direction 
chosen by the user with a pick point. You can offset lines, arcs, circles, ellipses, 2D polylines, 
xlines, rays and planar splines. 
 
Command: OFFSET  
Specify offset distance or [Through] <1.0>: (specify distance, as example 50)   
Select object to offset or <exit>: (select object, P1)  
Specify point on side to offset: (pick direction, P2)  
Select object to offset or <exit>: (to end or select another object to offset) 
 
Circles can be offset inside or outside of themselves to create a new circle which is concentric 
(has the same centre point) with the original circle. In the illustration, a new circle has been 
created outside of the original by picking a point outside of the original circle. The radius of 
the new circle is the offset distance "Offset" plus the radius of the original circle. 
 
The Array Command  

Toolbar:  
Pull-down: Modify>Array 
Keyboard: Array 
 
The Array command makes multiple copies of selected objects in a rectangular matrix 
(columns and rows) or a polar (circular) pattern. This command has been completely 
transformed in AutoCAD 2000i. It is now completely dialogue box driven with the option to see 
a preview of the array before it is created. You can also now create rectangular arrays at a 
user specified angle angle. This constitutes a major improvement in usability. 
 
The Rectangular Array 
 
The illustration on the right shows the results of a rectangular array with two columns 
an three rows. The distance between rows is indicated with the dimension DR and 
between columns with DC. When creating rectangular arrays it is important to 
remember that new rows are created above the original object and new columns are 
created to the right of the original object. The resulting array is, therefore, always 
created with the original object in the bottom left hand position with respect to the 
current co-ordinate system.  

Try creating this array yourself. First, draw a rectangle 20 drawing units wide and 
10 drawing units tall. To do this, start the rectangle command Draw>Rectangle 
from the pull-down menu. When you are prompted to pick a point, pick 
somewhere in the lower left quarter of the drawing area. Then, when you are 
prompted for a second point, enter the relative cartesian co-ordinate @20,10. 
You have now drawn a rectangle at the right size. 
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Rectangular Array 
 

Now start the Array command. First of all, make sure that the Rectangular Array 
radio button is selected and that you are looking at the Rectangular Array dialogue 
box and now follow the steps below: 
 

 

Rectangular Array dialogue box 

 
1. Click the Select objects button. The dialogue box will temporarily disappear enabling you 

to select the rectangle you just drew. Press the Return button on your keyboard to 
complete the selection. You are now returned to the dialogue box and the message 
immediately below the Select Objects button should read "1 objects selected".  

2. Enter the number of rows required in the Rows edit box. For this example, enter the value 
"3". Notice that the schematic preview on the right hand side of the dialogue box updates 
to reflect the values you are entering.  

3. Enter the number of columns required in the Columns edit box. Enter the value "2".  
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4. Enter the row offset in the Row Offset edit box. This is the distance DR in the illustration 
above. Note that this is not the distance between rows. In this example, our rectangle is 10 
units high and we will enter a row offset of 15. The result will be a 5 unit gap between 
rectangles.  

5. Enter the column offset in the Column Offset edit box. The same parameters apply as for 
the row offset. Enter a value of 25 to give a 5 unit gap between our rectangles.  

6.  Click on the Preview button. Once again, the dialogue box disappears and the specified 
array is temporarily drawn so that we can preview it. We are now offered 3 choices. If the 
array isn't quite right, click the Modify button to return to the Array dialogue box. If you are 
happy with the array, click the Accept button, the array will be permanently drawn and the 
command is ended.  

 
dialogue box: Array – Accept … 

 
The Polar Array 

The polar array works in a similar way to the rectangular array. The main difference is that 
rather than specifying the number and offset for rows and columns, you must specify a center 
point and the total number of objects in the array (including the original object). 

 

 
Rectangular Array dialogue box 

 

You can try this for yourself by drawing another rectangle as described above. This 
time, though, locate the rectangle in the centre top half of the drawing area. Now, 
start the Array command, click the Polar Array radio button and follow the steps 
below: 

1. Click the Select objects button. The dialogue box will temporarily disappear 
enabling you to select the rectangle you just drew. Press the Return button on 
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your keyboard to complete the selection. You are now returned to the 
dialogue box and the message immediately below the Select Objects button 
should read "1 objects selected".  

2. Specify the center point for the array. This is the point C in the illustration 
below. You can do this by entering x and y co-ordinates into the appropriate 
edit boxes if you know what these values should be. However, this is rarely 
the case and most often you will want to click the Pick Center Point button to 
pick a point from the drawing area. Pick a point somewhere below the 
rectangle you have just drawn. Enter a value for the total number of items. 
For this example, enter the value "6". Notice that once again, the schematic 
preview updates to reflect the values you have entered.  

3. Make sure that the Rotate items as copied checkbox is checked.  

4. Click on the Preview button. Once again, the dialogue box disappears and the 
specified array is temporarily drawn so that we can preview it. We are now 
offered 3 choices. If the array isn't quite right, click the Modify button to return 
to the Array dialogue box. If you are happy with the array, click the Accept 
button, the array will be permanently drawn and the command is ended.  

The array you have just drawn should look something like the one illustrated below, 
left. Take some time to play around with the other options in the Array dialogue box 
to see what they can do. 
 
Example:      

 
 
The Move Command  

Toolbar:  
Pull-down: Modify> Move 
Keyboard: MOVE or M   
The Move command works in a similar way to the Copy command except that no 
copy is made, the selected object(s) is simply moved from one location to another. 
 
Command: MOVE  
Select objects: (pick object to move, P1)  
Select objects: (to end selection) 
Specify base point or displacement: (pick P2)  
Specify second point of displacement  or <use first point as displacement>: (pick P3)  

Note that as with the Copy command, the two pick points, P2 and P3 are used only 
to indicate the distance and direction of movement. 
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The Rotate Command 

Toolbar:  
Pull-down: Modify> Rotate 
Keyboard: ROTATE or RO 
The Rotate command allows an object or objects to be rotated about a point selected 
by the user. AutoCAD prompts for a second rotation point or an angle which can be 
typed at the keyboard. 
Command: ROTATE  
Current positive angle in UCS: ANGDIR=counterclockwise ANGBASE=0 
Select objects: (pick object to rotate, P1)  
Select objects: (to end selection) 
Specify base point: (pick base point, P2)  
Specify rotation angle or [Reference]: (pick second point, P3 or enter angle) 
 
Remember, by default, AutoCAD angles start at 3 o'clock and increase in an anti-
clockwise direction. The "ANGDIR" and "ANGBASE" variables remind you of this. If 
you want to rotate in a clockwise direction you can enter a negative angle by using a 
minus sign. 
 
The Scale Command 

Toolbar:  
Pull-down: Modify> Scale 
Keyboard: SCALE or SC 

The Scale command can be used to change the size of an object or group of objects. 
You are prompted for a pick point about which the selection set will be scaled. 
Scaling can then be completed by picking a second point (not always easy because it 
can sometimes be difficult to precisely control the scaling) or by entering a scale 
factor at the keyboard. For example a scale factor of 2  will double the size of the 
objects in the selection set and a factor of 0.5 will half them. 

Command: SCALE  
Select objects: W ( or pick the screw ) 
Specify first corner: P1 
Specify opposite corner: P2 1 found 
Select objects: : (to end selection) 
Specify base point: P3  
Specify scale factor or [Reference]:2  (To double the size of the screw about P3) 

 
 

Scaling the object, SCALE FACTOR 2 
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Command: SCALE  
Select objects: W  
Specify first corner: (Pick P1) 
Specify opposite corner: (Pick P2) 1 found 
Select objects: : (to end selection) 
Specify base point: (Pick P3) 
Specify scale factor or [Reference]: R  
Specify reference length <1>:(Pick P4)  Specify second point: (Pick P5) 
Specify new length: 16  

 
Scaling the object, SCALE REFERENCE d → 16 

In the example shown above, the original tree symbol has been enlarged by 
dynamically scaling it using pick points to determine the change in scale. If you want 
to scale an object precisely, it is much easier to enter a scale factor using the 
keyboard. 
 
Note that the position of the new sized screw is determined by the location of the 
base point P3. 
  
The Trim Command 

Toolbar:  
Pull-down: Modify> Trim 
Keyboard: TRIM or TR 
 
The Trim command can be used to trim a part of an object. In order to trim an object 
you must draw a second object which forms the "cutting edge". Cutting edges can be 
lines, xlines, rays, polylines, circles, arcs or ellipses. Blocks and text cannot be 
trimmed or used as cutting edges. The Trim command, unlike most other modify 
commands requires that two separate object selections are made. The cutting edges 
are selected first (there can be one or more) and then the objects to be trimmed are 
selected. 
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Command: TRIM   
Current settings: Projection=UCS Edge=None 
Select cutting edges ... 
Select objects: (select the cutting edge, LINE P1) 
Select objects: (to end cutting edge selection) 
Select object to trim or shift-select to extend or [Project/Edge/Undo]:  

(pick the part of the CIRCLE which you want to trim,  P2) 
Select object to trim or shift-select to extend   

or [Project/Edge/Undo]: (pick the part of the LINE , P3) 
Select object to trim or shift-select to extend  

or [Project/Edge/Undo]: (to end) 
 

 
Trim Sequence from Right to Left 

 
Notice that at each trimming step you are given the option to undo the previous trim. 
This can be very useful if you inadvertently pick the wrong object. 
 
The Extend Command 

Toolbar:  
Pull-down: Modify> Extend 
Keyboard: EXTEND or EX 
 
This command extends a line, polyline or arc to meet another drawing object 
(known as the boundary edge). This command works in a similar way to the Trim 
command, described above. Two selections are made, one for the boundary edge(s) 
and one for the object(s) to extend. 
 
Lines and other objects can be extended in one of two directions. You can tell 
AutoCAD in which direction to extend by picking a point to the right or left of the 
midpoint respectively. AutoCAD does not intuitively know where the boundary edge 
lies so you must explicitly indicate the direction of extension by picking either one 
side or other of the midpoint.  
 
Command: EXTEND  
Current settings: Projection=UCS Edge=None 
Select boundary edges ... 
Select objects: (select the boundary edge, LINE P1) 
Select objects: (to end boundary edge selection) 
Select object to extend or shift-select to trim or [Project/Edge/Undo]: 

 (pick the object which you want to be extended,  LINE P2) 
Select object to extend or shift-select to trim or [Project/Edge/Undo]:  

(pick another object to be extended,  LINE P3) 
Select object to extend or shift-select to trim or [Project/Edge/Undo]: (to end) 
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Extend Sequence from Right to Left 
 
Sometimes you may get the message "Object does not intersect an edge" or "No 
edge in that direction". If this happens it means that you are either picking the wrong 
end of the object or the object you are trying to extend will not meet the boundary 
edge. The solution is either to pick near the end you want to extend or to move the 
boundary edge so that the extended line will intersect with it. 
 
The Chamfer Command 
Toolbar: Modify  >  
Pull-down: Modify > Chamfer  
Keyboard: CHAMFER  short-cut: CHA 
 
The Chamfer command enables you to create a chamfer between any two non-
parallel lines as in the illustration below or any two adjacent polyline segments. 
Usually, the Chamfer command is used to set the chamfer distances before drawing 
the chamfer. Follow the command sequence below where the chamfer distances are 
changed to 3 and 5 before the chamfer is made 
 
Example: Make a chamfer at the 25x16 rectangle drawn in by Line command. 
 
Command: CHAMFER  
(TRIM mode) Current chamfer Dist1 = 10.0000, Dist2 = 10.0000  
Select first line or [Polyline/Distance/Angle/Trim/Method]: D   (to set distances) 
Specify first chamfer distance <10.0000>: 3  
Specify second chamfer distance <20.0000>: 5  
Select first line or [Polyline/Distance/Angle/Trim/Method]: Pick vertical line 
Select second line: Pick horizontal line 
The chamfer is made and the command ends. 
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Example: Make a chamfer at the 25x16 rectangle drawn by Rec command. 
 
Command: CHAMFER  
(TRIM mode) Current chamfer Dist1 = 5, Dist2 = 3 
Select first line or [Polyline/Distance/Angle/Trim/Method]: D   
Specify first chamfer distance <5>: 3   
Specify second chamfer distance <4>: 5   
Select first line or [Polyline/Distance/Angle/Trim/Method]: P   
Select 2D polyline: Select a Rectangle 
4 lines were chamfered  
 
Notice from the command sequence that there are a number of options which can be 
used to control the way the Chamfer command behaves. The Polyline option can be 
used to chamfer all vertexes of a polyline simultaneously. The Distance option 
allows you to specify the two chamfer distances. Angle allows the angle between the 
first line and the chamfer to be specified. Trim is used to control whether the original 
lines are trimmed to the chamfer or remain as they are. Finally, Method is used to 
toggle the command between Distance and Angle mode. When Angle mode is used, 
the chamfer is defined using one distance and an angle rather than two distances. 
 
The Fillet Command 
Toolbar: Modify >  
Pull-down: Modify > Fillet 
Keyboard: Fillet   short-cut: F 
 
The Fillet command is a very useful tool which allows you to draw an arc between 
two intersecting lines or adjacent polyline segments. You first need to use the 
command to set the required radius and then a second time to select the two lines. 
 
Command: FILLET  
Current settings: Mode = TRIM, Radius = 10.0000 
Select first object or [Polyline/Radius/Trim]: R  
Specify fillet radius <10.000>: 10  
Select first object or [Polyline/Radius/Trim]: Pick vertical line 
Select second object : Pick horizontal line 
 

 
The Fillet command can also be used to fillet arcs and circles. The "Polyline" option 
also allows you to fillet all vertices of a polyline with a single command. It's worth 
experimenting with this command, it can save you lots of time and enables you to 
construct shapes which otherwise would be quite difficult. 
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Command: FILLET  
Current settings: Mode = TRIM, Radius = 5.0000 
Select first object or [Polyline/Radius/Trim]: P  
Select 2D polyline: Pick Rectangle 
4 lines were filleted 
 
The Explode Command 

Toolbar: Modify >  
Pull-down: Modify  > Explode 
Keyboard: EXPLODE  
 
The Explode command is used to "explode" single objects back to their constituent parts. In 
other words, the command is used to return blocks, polylines etc. (which may be composed of 
a number of component objects) back to their individual component parts. The change has no 
visible effect. 
 
The Lengthen Command 
Toolbar: Modify   
Pull-down: Modify Lengthen 
Keyboard: LENGTHEN short-cut: LEN 

The Lengthen command can often be used instead of either the Trim or Extend 

commands. Indeed the end result is exactly the same. The Lengthen command can 

be used to either lengthen or shorten Lines, Arcs, open Polylines, elliptical Arcs and 

open Splines without the use of cutting or boundary edges. 

Command Sequence 
Command: LENGTHEN  
Select an object or [DElta/Percent/Total/DYnamic]: DY  
Select an object to change or [Undo]: (select a line or arc) 
Specify new end point: (pick new end point) 
Select an object to change or [Undo]: (to end) 
 
Select an object to change or [Undo]:The command sequence above demonstrates 
the use of the Dynamic Lengthen option which is probably the most useful for general 
purpose drafting. However, the other options are worth getting to know because they 
can save lots of time and effort. 

Command: LENGTHEN  
Select an object or [DElta/Percent/Total/DYnamic]: T  
Specify total length or [Angle] <89.500)>: 93  
Select an object to change or [Undo]:  

The Total option allows you to change the total length of a line to any value that you 
specify. The Percent option allows you to change a line length using a percentage. 
For example, a value of 50 will result in a line one half the length of the original and a 
value of 200 will result in a line twice the length of the original. The Delta option can 
be used to extend or reduce the endpoint of a line by a given distance. The endpoint 
affected by the change is the one closest to the pick point when the object selection 
is made. 
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The Match Properties Command 
Toolbar:  
Pull-down: Modify Match Properties 
Keyboard MATCHPROP 
 
Another way to change the properties of an object or objects is to match the 
properties of any other object using the Match Properties command on the Standard 
toolbar. 
 
Command Sequence 
Command: MATCHPROP  
Select Source Object: (pick the object you wish to match) 
Current active settings = color layer ltype ltscale thickness text dim hatch 
Settings/<Select Destination Object(s)>: (pick the objects to inherit properties) 
Settings/<Select Destination Object(s)>:  
 
Creating blocks 
Command: Block (b)  
Block Definition dialogue box will appear 
Give NAME OF BLOCK, B1 as an 
Select objects: Specify opposite corner: 1 found  
Select objects:  
Specify insertion base point: int Of  
 
Dividing  lines into equal parts. 
 

Divide a given line, curve or spline into equal parts. 
 
Command: divide (div ) 
Select object to divide: Pick an object or line  
Enter the number of segments or [Block]: 5   (5 parts) 
 
Divide a given line into equal parts by using blocks. 
 
Command: div  
DIVIDE 
Select object to divide: pick an object 
Enter the number of segments or [Block]: b 
Enter name of block to insert: b1  
Align block with object? [Yes/No] <Y>:  
Enter the number of segments: 3  
 
Measure a certain-size parts on line, curve or spline 
 
Draw a 117 line and measure 50 unit equal parts on it. 
 

Command: measure   
Select object to measure: Pick an object   
Specify length of segment or [Block]: 50  (every part equal 50 mm)  
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Command: measure  
Select object to measure: Pick a line (object)  
Specify length of segment or [Block]: b  
Enter name of block to insert: a  
Align block with object? [Yes/No] <Y>:  
Specify length of segment: 150  
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Plotting  
When you have done the assignment, print it out. To do this, bring up the print dialog 
box using any method explained above (plot <enter> will work). Set it up to print as 
shown below. Follow these steps for a successful plot (see diagram below): 

1. Select your printer - laser or inkjet will work fine.  
2. Select the paper size - "A4" (297x210) is needed in this case. 
3. For the "Plot Area", select "Extents" - that will plot everything you drew. 
4. Select the checkbox to "Center the Plot" on your sheet of paper (looks 

better). 
5. If "Fit to Paper" is selected by default, uncheck it and select a scale of 1 inch 

to 1 paper unit. This will make your printout 'life-sized'. 
6. Now Preview your drawing. I strongly recommend that you preview EVERY 

drawing you will ever draw in AutoCAD - a lot can go wrong, so you don't 
want to waste paper (especially when you're using expensive 3'x4' sheets!).If 
your preview looks good, cancel out of it by clicking on the large red X icon. 

7. If you're sure that everything's ok (this is where good habits begin), press the 
OK button. 

 

 
Note: 

You may have to change the paper size in your printer (Use A4 as an example). 
You may also have to change the rotation or origin of the plot. Check the Landscape 
radio button in the Drawing Orientation section. 
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BLOCKS 

In this lesson you will be introduced to blocks. By definition, a BL60OCK is a 
collection of simple entities (lines, arcs, circles, text, etc.) that form a more complex 
entity that normally represents an object in the real world, e.g. a door, a chair, a 
window, a computer, valve ,transistor, diode and others.  

There are many advantages to using blocks, here the major ones: 
• Blocks are a single entity. This means that you can modify (move, copy, 

rotate) a block by selecting only one object in it. 
• You can build up a library of blocks consisting of the parts that you require 

many times in your workday. These blocks can be stored in a separate folder 
and even on a network so that all drafters have access to them. 

• Using blocks can help keep your file size down. AutoCAD stores block 
definitions in its database. When you insert a block, AutoCAD only stores the 
name of the block, its location (insertion point), scale and rotation. This can 
be very noticeable in large drawing. 

• If you need to change something, you can redefine a block. For example, you 
draw a chair and turn it into a block. Later, you're told that the size of the chair 
has changed. Since you used a block you can redefine the block and all of 
your chairs are updated automatically. If you had drawn (or copied) 100 
chairs in your drawing, you would have to manually change each one. 

• Blocks can also contain non-graphical information. This means text objects 
called attributes. For example, you have made blocks of different chairs. You 
can add information to the block such manufacturer, cost, weight, etc. This 
information stays with the block, but can also be extracted to a database or 
spreadsheet. This would be useful for things such as a bill of materials. 
Attributes can also be visible or invisible in your drawing. Another good use of 
attributes could be a title block. 

• You can even easily add internet hyperlinks to blocks so you can connect a 
block to a page on a supplier's online catalog.  

There are two types of blocks you can create: blocks that are internal to your current 
drawing, and those that are external, or saved as a separate file. To create the 
different types, different commands are used. 

Here are the commands that you will need for using blocks in this lesson: 

Command  Keystroke  Icon Menu  Result  

Block  Bmake/ B 
 

Draw > Block > 
Make  

Creates a block from 
separate entities (internal 
to current drawing) 

Write 
Block Wblock / W None None Creates a block and 

writes it to a file (external) 

Insert Insert / I 
 

Insert > Block Inserts a block (internal or 
external) 

 
Draw the computer as shown below. You do not have do dimension it. 
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Draw the computer as shown below. 
You do not have do dimension it. 
 
Start the BLOCK command by either 
typing B or using the pull down menu 
or the icon. You will see a dialog box 
that looks like the one shown (some 
versions of AutoCAD will have a 
slightly different dialog box (with 
different options). Enter information 
the same way though. 

.  

1 : The first thing that you want to do is give your block a name. Type COMPUTER in the edit 
box beside Block Name. 

2 : Now you need to select an insertion/base point. Pick the Pick Point button and then pick 
the midpoint of the bottom line. Make sure that the retain button is selected (this will keep 
your objects on the screen as individual objects.  

3 : Next you want to select the objects for your block. Pick the Select Objects button and 
then select all the parts of your computer and press <ENTER>. 

4 : Now select the drawing units you used to create the original objects in.  
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5 : This is optional, but you can add a description here. This is good if you are creating 
specific parts, like maybe a motor and want to add some quick specifications.  

6 : Pick the OK Button and the dialog box closes. It will look like nothing happened, but the 
drawing file now has a "Block Definition" for a Computer in it. Congratulations, you have 
created your first block. 

Now that you have created a block, it's time to insert it. Start the Insert command by typing I 
<ENTER>. You will see this dialog box on the screen: 

 
 

By default, all the options you need are pre-selected. Since you only have one block in your 
drawing, its name is displayed.  

Make sure that the Insertion Point - Specify On-screen box is checked, and the Explode 
button is not checked. The Scale - Specify On-screen should not be checked. Then press 
the OK button. Pick anywhere on your screen and you will see the block appear.  

Now insert a computer on every desk in your drawing. You can also copy the block instead of 
re-inserting each time, but make sure you know how to insert. 
 
ATTRIBUTES 
So far in using AutoCAD you have created geometry: lines, circles, etc. You have also added 
things such as text and dimensions. All of these things could also be done by hand, so 
what else does CAD have to offer? 

AutoCAD is also a database of information. Most of that database contains the information 
for reproducing what you have drawn, but you can also add information that is non-graphical. 
One of the easiest ways of adding non-graphical information is to use attributes. An attribute 
is text that can be attached to a block to convey more information than just the geometry on 
its own could convey. 
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Look at the two drawings below for an example: 

The first example shows some lines and arcs that could be anything. 

 
The second example shows the same geometry with the attributes visible so that you see 
what the shapes represent.  

 
 

The pictures above show a couch. The attributes describe what the model number, color and 
cost are as well as the manufacturer. From this simple example, you can see that AutoCAD 
has a useful tool for showing more than just geometry. 

This example shows information about furnishings in an office. Once you have drawn the 
floor plan, you could insert blocks of furniture that have information about the manufacturer, 
price, weight, and any other information you may need. This information can then be 
extracted out of AutoCAD and then used in a spreadsheet or other program which could 
generate a Bill of Materials. You can also use custom programs to use them in the CAD 
drawing. 

In this lesson you will be creating attributes and attaching them to the computer block that 
you made previously. Like everything you do in AutoCAD, there are particular steps involved 
when you work with attributes.  

1. First you have to define (or create) the attribute.  

2. Next you will create the block with attributes.  

3. Finally, when you insert the block you will give it the specific information.  

Many of the commands that you will be using are tough to remember at first. You may find it 
easier to use icons (but then the icons look very similar). Pull down menus are another 
option, so you can see exactly what the command is that you are starting. 
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Command  Keystroke  Icon  Menu  Result  

Define an 
attribute 

DDATTDEF 
/ ATT  

Draw > Block > 
Define Attribute 

Creates an attribute 
definition 

Edit 
attributes 

DDATTE / 
ATE <  

Modify> Object> 
Attrb.> Single 

Edits the contents 
of an existing 
attribute 

Block Block / 
Bmake  

Draw > Block > 
Make 

Creates a block 
from separate 
entities and 
attributes. 

Display Atts. ATTDISP  None None Hides or shows 
attributes  

Extract 
Attributes 

EATTEXT 
 

Tools > Attribute 
Extraction... 

Extracts attributes 
using the wizard  

 

Open up the floor plans you drew earlier with the Computer blocks. 

Insert a computer block and then explode it (type X <ENTER> and then select the block - 
press <ENTER>.)  

Begin the Attribute definition command: ATT (or) ATTDEF (or) DDATTDEF  
(AutoCAD has kept the commands from previous versions active in the new versions.)  

Look at the dialog box below. Fill in the edit boxes just like the example. Make sure to adjust 
the text height if necessary. 

What you did is give the attribute its definition - a name (tag), a prompt to help the user 

inserting it, and a (default) value . 

Once everything is entered, select the OK button. 

When you are back on the drawing screen, pick a point near the middle of the computer 
block. When you are done, the dialog box comes back so press OK. 
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Add the following attributes the same way, except instead of picking a point, check off the 
Align below previous attribute checkbox. 

TAG  PROMPT  VALUE  

MONITOR What is the MONITOR SIZE? XX" 

HDD What capacity is the Hard 
Drive? X.XXGB 

RAM  How much RAM is installed? XXXMB 

STATION What station is this  XXX 

 
Once all the attributes are created you should have something like this: 
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Now create a block that includes your four attributes. 
 
Start up the BLOCK command. Create it as shown in the previous lesson. When you are 
asked for the block name, give it the name COMP-AT.  

Insert the block and you will get a dialog box where you can enter the values for the tags. 
You will be prompted to provide answers to the prompts that you defined in the attributes. 

Command: I  INSERT  
Specify insertion point or 
[Scale/X/Y/Z/Rotate/PScale/PX/PY/PZ/PRotate]: 
Enter attribute values 
What is the CPU Speed <XXX GHz>: 2.6 GHz  
What is the monitor size <XX">: 21"  
What is the capacity of the Hard Drive <XXX Gb>: 200Gb  
How much ram is installed <XXX Mb>: 1024Mb  

After inserting the block and answering all the prompts, your block should look like this: 

 
Now by looking at the drawing, you can see exactly what type of computer it is and what 
station (location) it is. How much handier is THAT?  
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Autocad Summary 

CTRL+0: Toggles Clean Screen  
CTRL+1: Toggles the Properties palette 
CTRL+2: Toggles the DesignCenter palette 
CTRL+3: Toggles the Tool Palettes Window  
CTRL+4: Toggles the Sheet Set Manager  
CTRL+6: Toggles the dbConnect Manager  
CTRL+7: Toggles the Markup Set Manager  
CTRL+8: Toggles the QuickCalc calculator palette  
CTRL+9: Toggles the command window 
CTRL+A: Selects all objects in the drawing 
CTRL+SHIFT+A: Toggles Groups 
CTRL+B: Toggles Snap mode  
CTRL+C: Copies objects to Clipboard 
CTRL+SHIFT+C: Copies objects to Clipboard with Base Point 
CTRL+D: Toggles Dynamic UCS 
CTRL+E: Cycles through isometric planes 
CTRL+F: Toggles running object snaps 
CTRL+G: Toggles the grid 
CTRL+H: Toggles PICKSTYLE 
CTRL+I: Toggles COORDS 
CTRL+J; CTRL+M: Repeats the last command (pressing Enter does the same)  
CTRL+L: Toggles Ortho mode 
CTRL+N: Creates a new drawing 
CTRL+O: Opens an existing drawing 
CTRL+P: Prints/plots thecurrent drawing 
CTRL+R: Cycles through layout viewports 
CTRL+S: Saves the current drawing 
CTRL+SHIFT+S: Opens the Save As dialog box 
CTRL+T: Toggles TABLET mode 
CTRL+V: Pastes data from the Clipboard 
CTRL+SHIFT+V: Pastes data from the Clipboard as a Block 
CTRL+X: Cuts objects to Clipboard 
CTRL+Y: Cancels the preceding Undo action 
CTRL+Z: Reverses the last action 
CTRL+[; CTRL+\: Cancels the current command (pressing Esc does the same)  
CTRL+PAGE UP: Moves to the next layout tab to the left of the current tab 
CTRL+PAGE DOWN: Moves to the next layout tab to the right of the current tab 
ALT+F11: Displays the Visual Basic Editor 
ALT+F8: Displays the Macros dialog box 
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Shortcut Keys for AutoCAD 
 
A Arc ICL IMAGECLIP 
AR Array IM IMAGE 
AT Attributes -IM IMAGE 
BR Break IMP IMPORT 
C Circle IN INTERSECT 
CH Properties INF INTERFERE 
D Dimension Style IO INSERTOBJ 
DI Distance L LINE 
DO Donut LA LAYER 
DT Dtext -LA LAYER 
E Erase LE LEADER 
ED Ddedit LEN LENGTHEN 
EL Ellipse LI LIST 
EX Extend LS LIST 
F Fillet LT LINETYPE 
F1 Help  -LT LINETYPE 
F2 Text Window LTS LTSCALE 
F3 Object Snap Menu M MOVE 
F5 Isoplane Toggle MA MATCHPROP 
F6 Coordinates ME MEASURE 
F7 Grid Toggle MI MIRROR 
F8 Ortho Toggle ML MLINE 
F9 Snap Toggle MO DDMODIFY 
FI  FILTER MS MSPACE 
G GROUP MT MTEXT 
-G GROUP MV MVIEW 
GR DDGRIPS O OFFSET 
H BHATCH OS DDOSNAP 
-H HATCH -OS -OSNAP 
HE HATCHEDIT P PAN 
HI HIDE -P -PAN 
I DDINSERT ICL IMAGECLIP 
-I INSERT IM IMAGE 
IAD IMAGEADJUST -IM IMAGE 
IAT IMAGEATTACH IMP IMPORT 
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PA PASTESPEC AT DDATTDEF 
PE PEDIT -AT ATTDEF 
PL PLINE ATE DDATTE 
PO POINT -ATE ATTEDIT 
POL POLYGON B BMAKE 
PR PREFERENCES -B BLOCK 
PRE PREVIEW BH BHATCH 
PRINT PLOT BO BOUNDARY 
PS PSPACE -BO -BOUNDARY 
PU PURGE BR BREAK 
R REDRAW C CIRCLE 
RA REDRAWALL CH DDCHPROP 
RE REGEN -CH CHANGE 
REA REGENALL CHA CHAMFER 
REC RECTANGLE COL DDCOLOR 
3A 3DARRAY CO COPY 
3F 3DFACE D DDIM 
3P 3DPOLY DAL DIMALIGNED 
A ARC DAN DIMANGULAR 
AA AREA DBA DIMBASELINE 
AL ALIGN DCE DIMCENTER 
AP APPLOAD DCO DIMCONTINUE 
AR ARRAY DDI DIMDIAMETER 
AAD ASEADMIN DED DIMEDIT 
AEX ASEEXPORT DI DIST 
ALI ASELINKS DIV DIVIDE 
ASQ ASESQLED DLI DIMLINEAR 
ARO ASEROWS DO DONUT 
ASE ASESELECT DOR DIMORDINATE 
PA PASTESPEC DOV DIMOVERRIDE 
PE PEDIT DR DRAWORDER 
PL PLINE DRA DIMRADIUS 
PO POINT DST DIMSTYLE 
POL POLYGON DT DTEXT 
  DV DVIEW 
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E ERASE MI Mirror 
ED DDEDIT ML Multiline Text 
EL ELLIPSE MT Multiline Text 
EX EXTEND O Offset 
EXIT QUIT OS Object Snap Menu 
EXP EXPORT P Pan 
EXT EXTRUDE P Previous Selection 
F FILLET PE Polyline Edit 
REC RECTANGLE PL Polyline 
REG REGION PR Preferences 
REN DDRENAME R Redraw 
-REN RENAME R Remove from Selection 
REV REVOLVE RE Regenerate 
RM DDRMODES REC Rectangle 
RO ROTATE RM Drawing Aids 
RPR RPREF RO Rotate 
RR RENDER S Stretch 
S STRETC SC SCALE 
GR Grips SCR SCRIPT 
H Hatch SE DDSELECT 
HI Hide SEC SECTION 
L Line SET SETVAR 
LA Layers SHA SHADE 
LE Leader SL SLICE 
LEN     Lengthen SN SNAP 
LI List SO SOLID 
LT Linetype SP SPELL 
M Move SPL SPLINE 
MA Match Property SPE SPLINEDIT 
ME Measure ST STYLE 
E ERASE MI Mirror 
ED DDEDIT ML Multiline Text 
EL ELLIPSE MT Multiline Text 
EX EXTEND O Offset 
EXIT QUIT OS Object Snap Menu 
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SU SUBTRACT T Text 
T MTEXT TI Tilemode 
-T -MTEXT TO Toolbars 
TA TABLET TR Trim 
TH THICKNESS U Undo 
TI TILEMODE X Explode 
TO TOOLBAR Z Zoom 
TOL TOLERANCE   
TOR TORUS   
TR TRIM   
UC DDUCS   
UCP DDUCSP   
UN DDUNITS   
-UN UNITS   
UNI UNION   
V DDVIEW   
-V VIEW   
VP DDVPOINT   
-VP VPOINT   
W WBLOCK   
WE WEDGE   
X EXPLODE   
XA XATTACH   
XB XBIND   
-XB -XBIND   
XC XCLIP   
XL XLINE   
XR XREF   
-XR -XREF   
Z ZOOM   
SU SUBTRACT   
T MTEXT   
-T -MTEXT   
TA TABLET   
TH THICKNESS   
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